GWs down - Cannot create or access GWs
Incident Report for Axonize
Postmortem

Issue occurred while running a planned upgrade Kubernetes using the Azure provided method of upgrading the clusters. Process was carefully tested initially on both our Dev and STG environments which revealed some issues we resolved so they don’t occur once upgrading Production.

During the Production cluster upgrades the backend upgrades were taking a considerate amount of time on the Azure end. We engaged Microsoft and monitored their work trying to expedite the process. During the course of the backend nodes being upgraded to some services went into a degraded state. In this case the Inbound load balancer was having some deployment issues that automatically resolved once the cluster upgrade completed.

Posted Jun 29, 2023 - 17:36 IDT

Resolved
Issue fully resolved
Posted Jun 27, 2023 - 14:06 IDT
Identified
We are progressing in resolving the issue. we will continue to update.
Posted Jun 27, 2023 - 13:30 IDT
Investigating
During infrastructure upgrade an Azure issue was identified. A blocker ticket was raised with Microsoft support who are working on resolving. We are in constant contact with Azure Support for updates.
Posted Jun 27, 2023 - 13:01 IDT
This incident affected: Stream Analytics, Rules Engine, and IotHub.